summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/libewf/libewf-20100226-r1.ebuild')
-rw-r--r--app-forensics/libewf/libewf-20100226-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-forensics/libewf/libewf-20100226-r1.ebuild b/app-forensics/libewf/libewf-20100226-r1.ebuild
new file mode 100644
index 000000000000..7959d86215a4
--- /dev/null
+++ b/app-forensics/libewf/libewf-20100226-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20100226-r1.ebuild,v 1.1 2011/08/16 13:17:54 patrick Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="ewf2 debug rawio unicode"
+
+DEPEND="
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable unicode wide-character-type) \
+ $(use_enable rawio low-level-functions) \
+ $(use_enable debug verbose-output) \
+ $(use_enable debug debug-output) \
+ $(use_enable ewf2 v2-api) || die "Failed to configure"
+}
+src_compile() {
+ emake || die "Failed to build"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README documents/*.txt
+ doman manuals/*.1 manuals/*.3
+}