summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/dia/dia-0.92_pre4.ebuild')
-rw-r--r--app-office/dia/dia-0.92_pre4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-office/dia/dia-0.92_pre4.ebuild b/app-office/dia/dia-0.92_pre4.ebuild
new file mode 100644
index 000000000000..4563de7ced27
--- /dev/null
+++ b/app-office/dia/dia-0.92_pre4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.92_pre4.ebuild,v 1.1 2003/10/10 21:30:19 liquidx Exp $
+
+inherit gnome2 python
+
+DESCRIPTION="Diagram Creation Program"
+HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
+# remove after it moves out of _pre
+SRC_URI="mirror://gnome/sources/${PN}/0.92/${P/_/-}.tar.bz2"
+S=${WORKDIR}/${P/_/-}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="gnome png python"
+
+DEPEND=">=x11-libs/gtk+-2.0.0
+ >=x11-libs/pango-1.2.4
+ >=dev-libs/libxml2-2.3.9
+ >=dev-libs/libxslt-1.0
+ >=media-libs/freetype-2.0.9
+ >=dev-util/intltool-0.21
+ >=sys-libs/zlib-1.1.4
+ png? ( media-libs/libpng
+ media-libs/libart_lgpl )
+ gnome? ( >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0 )
+ python? ( >=dev-lang/python-2.0
+ >=dev-python/pygtk-1.99 )"
+
+G2CONF="${G2CONF} $(use_enable gnome) $(use_with python)"
+
+src_install() {
+
+ make DESTDIR=${D} install || die "install failed"
+
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+
+ # fix .desktop link
+ dodir /usr/share/applications
+ mv ${D}/usr/share/gnome/apps/Applications/dia.desktop ${D}/usr/share/applications/dia.desktop
+ rmdir ${D}/usr/share/gnome/apps/Applications
+ rmdir ${D}/usr/share/gnome/apps
+ echo "Categories=Application;GNOME;Office;" >> ${D}/usr/share/applications/dia.desktop
+
+}