summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/tcsh/tcsh-6.10-r2.ebuild')
-rw-r--r--app-shells/tcsh/tcsh-6.10-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-shells/tcsh/tcsh-6.10-r2.ebuild b/app-shells/tcsh/tcsh-6.10-r2.ebuild
new file mode 100644
index 000000000000..10aac65bd6aa
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.10-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r2.ebuild,v 1.1 2001/12/13 23:40:03 kabau Exp $
+
+S=${WORKDIR}/${P}.00
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+#ugh, astron.com doesn't support passive ftp... maybe another source?
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ perl? ( sys-devel/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --prefix=/ --mandir=/usr/share/man --host=${CHOST}
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install install.man
+ if [ "`use perl`" ]
+ then
+ try perl tcsh.man2html
+ docinto html
+ dodoc tcsh.html/*.html
+ fi
+ dosym tcsh /bin/csh
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ insinto /etc
+ doins ${FILESDIR}/csh.cshrc ${FILESDIR}/csh.login
+}
+
+
+