summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/hunspell/files/hunspell-1.1.4-libtool.patch')
-rw-r--r--app-text/hunspell/files/hunspell-1.1.4-libtool.patch103
1 files changed, 103 insertions, 0 deletions
diff --git a/app-text/hunspell/files/hunspell-1.1.4-libtool.patch b/app-text/hunspell/files/hunspell-1.1.4-libtool.patch
new file mode 100644
index 000000000000..e7915e032b11
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.1.4-libtool.patch
@@ -0,0 +1,103 @@
+Index: hunspell-1.1.4/configure.ac
+===================================================================
+--- hunspell-1.1.4.orig/configure.ac
++++ hunspell-1.1.4/configure.ac
+@@ -23,7 +23,7 @@ AC_CONFIG_HEADER([config.h])
+ # Checks for programs.
+ AC_PROG_CXX
+ AC_PROG_CC
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ # Checks for libraries.
+
+Index: hunspell-1.1.4/src/hunspell/Makefile.am
+===================================================================
+--- hunspell-1.1.4.orig/src/hunspell/Makefile.am
++++ hunspell-1.1.4/src/hunspell/Makefile.am
+@@ -1,5 +1,5 @@
+-lib_LIBRARIES = libhunspell.a
+-libhunspell_a_SOURCES=affentry.cxx affixmgr.cxx csutil.cxx \
++lib_LTLIBRARIES = libhunspell.la
++libhunspell_la_SOURCES=affentry.cxx affixmgr.cxx csutil.cxx \
+ dictmgr.cxx hashmgr.cxx hunspell.cxx \
+ suggestmgr.cxx utf_info.cxx license.myspell license.hunspell
+
+Index: hunspell-1.1.4/src/hunspell/utf_info.cxx
+===================================================================
+--- hunspell-1.1.4.orig/src/hunspell/utf_info.cxx
++++ hunspell-1.1.4/src/hunspell/utf_info.cxx
+@@ -1,6 +1,6 @@
+ #include "csutil.hxx"
+ /* fields: Unicode letter, toupper, tolower */
+-struct unicode_info utf_lst[] = {
++static struct unicode_info utf_lst[] = {
+ { 0x0041, 0x0041, 0x0061 },
+ { 0x0042, 0x0042, 0x0062 },
+ { 0x0043, 0x0043, 0x0063 },
+Index: hunspell-1.1.4/src/parsers/Makefile.am
+===================================================================
+--- hunspell-1.1.4.orig/src/parsers/Makefile.am
++++ hunspell-1.1.4/src/parsers/Makefile.am
+@@ -1,7 +1,8 @@
+-lib_LIBRARIES=libparsers.a
+-libparsers_a_SOURCES=firstparser.cxx htmlparser.cxx \
++lib_LTLIBRARIES=libparsers.la
++libparsers_la_SOURCES=firstparser.cxx htmlparser.cxx \
+ latexparser.cxx manparser.cxx \
+ textparser.cxx
++libparsers_la_LIBADD = ../hunspell/libhunspell.la
+
+ #include_hunspelldir
+ include_HEADERS = firstparser.hxx \
+@@ -11,7 +12,6 @@ include_HEADERS = firstparser.hxx \
+ textparser.hxx
+
+ noinst_PROGRAMS=testparser
+-testparser_SOURCES=firstparser.cxx firstparser.hxx htmlparser.cxx htmlparser.hxx latexparser.cxx latexparser.hxx manparser.cxx manparser.hxx testparser.cxx textparser.cxx textparser.hxx
++testparser_SOURCES=testparser.cxx
++testparser_LDADD = libparsers.la
+
+-# need mystrdup()
+-LDADD = ../hunspell/libhunspell.a
+Index: hunspell-1.1.4/src/tools/Makefile.am
+===================================================================
+--- hunspell-1.1.4.orig/src/tools/Makefile.am
++++ hunspell-1.1.4/src/tools/Makefile.am
+@@ -7,18 +7,18 @@ unmunch_SOURCES=unmunch.c
+ include_HEADERS=munch.h unmunch.h
+
+ example_SOURCES=example.cxx
+-example_LDADD = ../hunspell/libhunspell.a
++example_LDADD = ../hunspell/libhunspell.la
+
+ hunspell_SOURCES=hunspell.cxx
+-hunspell_LDADD = @LIBINTL@ ../hunspell/libhunspell.a \
+- ../parsers/libparsers.a @CURSESLIB@ @READLINELIB@
++hunspell_LDADD = @LIBINTL@ ../hunspell/libhunspell.la \
++ ../parsers/libparsers.la @CURSESLIB@ @READLINELIB@
+
+ hunmorph_SOURCES=hunmorph.cxx
+-hunmorph_LDADD = ../hunspell/libhunspell.a
++hunmorph_LDADD = ../hunspell/libhunspell.la
+ #hunmorph_INCLUDES=-I${top_srcdir}/src/hunspell
+
+ hunstem_SOURCES=hunstem.cxx
+-hunstem_LDADD = ../hunspell/libhunspell.a
++hunstem_LDADD = ../hunspell/libhunspell.la
+ #hunstem_INCLUDES=-I${top_srcdir}/src/hunspell
+
+ EXTRA_DIST=makealias
+Index: hunspell-1.1.4/po/Makefile.in.in
+===================================================================
+--- hunspell-1.1.4.orig/po/Makefile.in.in
++++ hunspell-1.1.4/po/Makefile.in.in
+@@ -27,7 +27,7 @@ gettextsrcdir = $(datadir)/gettext/po
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = @MKINSTALLDIRS@
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@