summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vcscommand/vcscommand-0.1_beta29.ebuild')
-rw-r--r--app-vim/vcscommand/vcscommand-0.1_beta29.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-vim/vcscommand/vcscommand-0.1_beta29.ebuild b/app-vim/vcscommand/vcscommand-0.1_beta29.ebuild
new file mode 100644
index 000000000000..8d0eecc5473f
--- /dev/null
+++ b/app-vim/vcscommand/vcscommand-0.1_beta29.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vcscommand/vcscommand-0.1_beta29.ebuild,v 1.1 2009/07/09 10:25:59 fauli Exp $
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: CVS/SVN/SVK integration plugin"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=90"
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="cvs git subversion svk"
+
+RDEPEND="cvs? ( dev-util/cvs )
+ git? ( dev-util/git )
+ subversion? ( dev-util/subversion )
+ svk? ( dev-util/svk )
+ !app-vim/cvscommand
+ !app-vim/calendar" # conflict, bug 62677
+
+VIM_PLUGIN_HELPFILES="vcscommand"
+
+no_flags_die() {
+ eerror "Please choose at least one VCS system"
+ eerror "to be supported by this plugin."
+ die "No vcs systems set"
+}
+
+pkg_setup() {
+ elog "Note: Support for all VCS systems are enabled by use flags."
+ elog " Make sure you've enabled the flags you want."
+
+ use cvs || use git || use subversion || use svk || no_flags_die
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use cvs || rm syntax/CVSAnnotate.vim plugin/vcscvs.vim
+ use git || rm plugin/vcsgit.vim
+ use subversion || rm syntax/SVNAnnotate.vim plugin/vcssvn.vim
+ use svk || rm syntax/SVKAnnotate.vim plugin/vcssvk.vim
+}