summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/fgl/fgl-5.4.1.1.ebuild')
-rw-r--r--dev-haskell/fgl/fgl-5.4.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-haskell/fgl/fgl-5.4.1.1.ebuild b/dev-haskell/fgl/fgl-5.4.1.1.ebuild
new file mode 100644
index 000000000000..cc86bdd262fc
--- /dev/null
+++ b/dev-haskell/fgl/fgl-5.4.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fgl/fgl-5.4.1.1.ebuild,v 1.1 2007/12/13 17:48:22 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal versionator
+
+DESCRIPTION="A functional graph library for Haskell."
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.4
+ dev-haskell/mtl"
+
+src_unpack() {
+ unpack "${A}"
+
+ if ! version_is_at_least "6.8" "$(ghc-version)"; then
+ sed -i -e 's/, containers, array//' "${S}/fgl.cabal"
+ fi
+}