summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/x11/x11-1.4.1.ebuild')
-rw-r--r--dev-haskell/x11/x11-1.4.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-haskell/x11/x11-1.4.1.ebuild b/dev-haskell/x11/x11-1.4.1.ebuild
new file mode 100644
index 000000000000..831cd4a147d2
--- /dev/null
+++ b/dev-haskell/x11/x11-1.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.1.ebuild,v 1.1 2007/12/15 23:11:47 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+CABAL_MIN_VERSION=1.1.6
+inherit haskell-cabal
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="http://darcs.haskell.org/X11"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.4.2
+ x11-libs/libX11"
+
+S="${WORKDIR}/${MY_P}"