summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/blitz/blitz-0.7.ebuild')
-rw-r--r--dev-libs/blitz/blitz-0.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/blitz/blitz-0.7.ebuild b/dev-libs/blitz/blitz-0.7.ebuild
new file mode 100644
index 000000000000..799c3e226be3
--- /dev/null
+++ b/dev-libs/blitz/blitz-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.7.ebuild,v 1.1 2004/03/02 18:28:56 pbienst Exp $
+
+inherit base
+
+S=${WORKDIR}/Blitz++-${PV}
+DESCRIPTION="High-performance C++ numeric library"
+SRC_URI="mirror://sourceforge/${PN/-/}/Blitz++-${PV}.tar.gz"
+HOMEPAGE="http://www.oonumerics.org/blitz"
+DEPEND="app-text/tetex
+ icc? ( dev-lang/icc )"
+IUSE="icc"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+PATCHES1=${FILESDIR}/blitz-0.7.diff
+
+src_compile() {
+ local myconf
+ # ICC: if we've got it, use it
+ use icc && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
+
+ ./configure ${myconf}
+ emake lib || die
+}
+
+src_install () {
+
+ einstall || die
+ dodoc ChangeLog ChangeLog.1 LICENSE README README.binutils \
+ TODO COPYING LEGAL AUTHORS NEWS
+}