summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild
index 9898b2882a3c..ca16aa515db7 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild,v 1.8 2009/03/25 03:35:39 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.4.ebuild,v 1.9 2009/04/05 05:39:48 arfrever Exp $
-inherit eutils
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
HOMEPAGE="http://www.gnupg.org/"
@@ -17,6 +17,10 @@ IUSE=""
RDEPEND=">=dev-libs/libgpg-error-1.5"
DEPEND="${RDEPEND}"
+pkg_setup() {
+ [[ $(tc-arch) == x86 && $(gcc-version) == 4.1 ]] && replace-flags -O3 -O2
+}
+
src_compile() {
# --disable-padlock-support for bug #201917
econf \