summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/yaz')
-rw-r--r--dev-libs/yaz/ChangeLog7
-rw-r--r--dev-libs/yaz/yaz-3.0.50.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-libs/yaz/ChangeLog b/dev-libs/yaz/ChangeLog
index 31d07d005819..71d7a32a4ec9 100644
--- a/dev-libs/yaz/ChangeLog
+++ b/dev-libs/yaz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/yaz
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.59 2009/10/19 08:35:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.60 2009/11/08 13:39:31 patrick Exp $
+
+*yaz-3.0.50 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +yaz-3.0.50.ebuild:
+ Bump
19 Oct 2009; Mike Frysinger <vapier@gentoo.org>
files/yaz-3.0.26-icu-automagic.patch:
diff --git a/dev-libs/yaz/yaz-3.0.50.ebuild b/dev-libs/yaz/yaz-3.0.50.ebuild
new file mode 100644
index 000000000000..69638bbe5fc3
--- /dev/null
+++ b/dev-libs/yaz/yaz-3.0.50.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-3.0.50.ebuild,v 1.1 2009/11/08 13:39:31 patrick Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/yaz"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug icu tcpd ziffy"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/openssl
+ icu? ( dev-libs/icu )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ziffy? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/tcl
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.47-icu-automagic.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_enable debug memdebug) \
+ $(use_enable icu) \
+ $(use_enable tcpd tcpd /usr)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodir ${docdir}/html
+ mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc ChangeLog NEWS README
+}