summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/gcl/gcl-2.6.7.ebuild')
-rw-r--r--dev-lisp/gcl/gcl-2.6.7.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/dev-lisp/gcl/gcl-2.6.7.ebuild b/dev-lisp/gcl/gcl-2.6.7.ebuild
index 303b44e134f8..c59af8ff5e32 100644
--- a/dev-lisp/gcl/gcl-2.6.7.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7.ebuild,v 1.11 2008/04/20 22:00:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7.ebuild,v 1.12 2008/09/03 21:42:59 opfer Exp $
inherit elisp-common flag-o-matic autotools
@@ -20,16 +20,16 @@ RDEPEND="emacs? ( virtual/emacs )
tk? ( dev-lang/tk )"
DEPEND="$RDEPEND
- doc? ( virtual/tetex )
+ doc? ( virtual/texi2dvi )
>=app-text/texi2html-1.64
>=sys-devel/autoconf-2.52"
src_unpack() {
unpack ${A}
- sed -e "s/gcl-doc/${PF}/g" ${S}/info/makefile > ${T}/makefile
- mv ${T}/makefile ${S}/info/makefile
- epatch ${FILESDIR}/${PV}-fix-configure.in-gentoo.patch || die
- epatch ${FILESDIR}/${P}-fix-configure.in-bfd.patch || die
+ sed -e "s/gcl-doc/${PF}/g" "${S}"/info/makefile > "${T}"/makefile
+ mv "${T}"/makefile "${S}"/info/makefile
+ epatch "${FILESDIR}"/${PV}-fix-configure.in-gentoo.patch
+ epatch "${FILESDIR}"/${P}-fix-configure.in-bfd.patch
eautoconf || die
}
@@ -128,18 +128,18 @@ ${myconfig}"
src_install() {
export SANDBOX_ON=0
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
- rm -rf ${D}/usr/lib/${P}/info
- mv ${D}/default.el elisp/
+ rm -rf "${D}"/usr/lib/${P}/info
+ mv "${D}"/default.el elisp/
if use emacs; then
- mv elisp/add-default.el ${T}/50gcl-gentoo.el
- elisp-site-file-install ${T}/50gcl-gentoo.el
+ mv elisp/add-default.el "${T}"/50gcl-gentoo.el
+ elisp-site-file-install "${T}"/50gcl-gentoo.el
elisp-install ${PN} elisp/*
fperms 0644 /usr/share/emacs/site-lisp/gcl/*
else
- rm -rf ${D}/usr/share/emacs
+ rm -rf "${D}"/usr/share/emacs
fi
dosed /usr/bin/gcl
@@ -155,11 +155,11 @@ src_install() {
dodoc readme* RELEASE* ChangeLog* doc/*
- for i in ${D}/usr/share/doc/gcl-{tk,si}; do
- mv $i ${D}/usr/share/doc/${PF}
+ for i in "${D}"/usr/share/doc/gcl-{tk,si}; do
+ mv $i "${D}"/usr/share/doc/${PF}
done
- find ${D}/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
+ find "${D}"/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
}
pkg_postinst() {