summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gauche/Manifest4
-rw-r--r--dev-lisp/gauche/files/digest-gauche-0.7.4.11
-rw-r--r--dev-lisp/gauche/gauche-0.7.4.1.ebuild65
3 files changed, 68 insertions, 2 deletions
diff --git a/dev-lisp/gauche/Manifest b/dev-lisp/gauche/Manifest
index 1a2eff138508..b725c997fe72 100644
--- a/dev-lisp/gauche/Manifest
+++ b/dev-lisp/gauche/Manifest
@@ -1,8 +1,8 @@
-MD5 94664acac4722a6f93caf3bb1692f77c ChangeLog 2257
+MD5 8eda73c8dfdc426c1633b80d036877c2 ChangeLog 2381
MD5 6a21b07bf6299fc4dd7db757b056da94 gauche-0.7.1.ebuild 1265
MD5 383ef183d554cc7c9b8afbfbfc12f676 gauche-0.7.2.ebuild 1395
MD5 e7029a0cbcd7430a3dae2f87b5daabb3 gauche-0.7.3.ebuild 1397
-MD5 4098ebf5b323fa61582196b887955d9a gauche-0.7.4.1.ebuild 1114
+MD5 fdb7f09c13b5e838a06b3f0ab27dbd5c gauche-0.7.4.1.ebuild 1214
MD5 681d1885ce4490fd7c2d537a30a943de metadata.xml 618
MD5 8e1c8c57c6a2b38a3d62148d0e358a91 files/digest-gauche-0.7.1 62
MD5 cba997bb32757ee9b5991d5dde1b6d6a files/digest-gauche-0.7.2 62
diff --git a/dev-lisp/gauche/files/digest-gauche-0.7.4.1 b/dev-lisp/gauche/files/digest-gauche-0.7.4.1
new file mode 100644
index 000000000000..a0c114b64545
--- /dev/null
+++ b/dev-lisp/gauche/files/digest-gauche-0.7.4.1
@@ -0,0 +1 @@
+MD5 21ab94ccba8bb9200b8c0a09c2b1f02e Gauche-0.7.4.1.tgz 2399260
diff --git a/dev-lisp/gauche/gauche-0.7.4.1.ebuild b/dev-lisp/gauche/gauche-0.7.4.1.ebuild
new file mode 100644
index 000000000000..c73fbe075a52
--- /dev/null
+++ b/dev-lisp/gauche/gauche-0.7.4.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/gauche-0.7.4.1.ebuild,v 1.1 2004/02/06 09:35:58 hattya Exp $
+
+inherit flag-o-matic
+
+IUSE="ipv6 nls"
+
+MY_P="${P/g/G}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=sys-libs/gdbm-1.8.0"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gdbm-gentoo.diff
+ autoconf
+
+}
+
+src_compile() {
+
+ local myconf mycflags
+
+ use ipv6 && myconf="--enable-ipv6"
+
+ if use nls; then
+ myconf="${myconf} --enable-multibyte=utf-8"
+ else
+ myconf="${myconf} --enable-multibyte=euc-jp"
+ fi
+
+ sed -i -e "67s/\$(LIB_INSTALL_DIR)/\$(DISTDIR)\$(LIB_INSTALL_DIR)/" src/Makefile.in
+
+
+ filter-flags -fforce-addr
+
+ mycflags=${CFLAGS}
+ unset CFLAGS CXXFLAGS
+
+ econf ${myconf} --enable-threads=pthreads || die
+ emake OPTFLAGS="${mycflags}" || die
+
+ make -s check || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL INSTALL.eucjp README
+
+}