summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fieldslib/fieldslib-0.1.1.ebuild')
-rw-r--r--dev-ml/fieldslib/fieldslib-0.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/fieldslib/fieldslib-0.1.1.ebuild b/dev-ml/fieldslib/fieldslib-0.1.1.ebuild
new file mode 100644
index 000000000000..6b1883651acf
--- /dev/null
+++ b/dev-ml/fieldslib/fieldslib-0.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/fieldslib/fieldslib-0.1.1.ebuild,v 1.1 2011/01/20 19:53:13 aballier Exp $
+
+EAPI="2"
+inherit findlib multilib
+
+DESCRIPTION="Folding over record fields"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt]
+ dev-ml/type-conv"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README || die
+}