summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-4.26.3.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-4.26.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-4.26.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-4.26.3.ebuild
new file mode 100644
index 000000000000..6261a5e5a569
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-4.26.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-4.26.3.ebuild,v 1.1 2002/06/29 05:34:05 george Exp $
+
+DESCRIPTION="Perl Compatibility Regular Expressions for OCaml"
+HOMEPAGE="http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.04-r1
+ >=dev-libs/libpcre-3.9-r1"
+RDEPEND="${DEPEND}"
+
+SRC_URI="http://www.ai.univie.ac.at/~markus/ocaml_sources/pcre-ocaml-4.26.3.tar.bz2"
+S=${WORKDIR}/${P}
+
+SLOT="3"
+
+src_compile() {
+ make all opt || die
+}
+
+src_install () {
+ make OCAMLLIBPATH=${D}/usr/lib/ocaml install || die
+ mv ${D}/usr/lib/ocaml/contrib/* ${D}/usr/lib/ocaml || die
+ rmdir ${D}/usr/lib/ocaml/contrib || die
+
+ dodoc LICENSE README VERSION META
+}