summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/WWW-Mechanize/WWW-Mechanize-1.22.ebuild')
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.22.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.22.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.22.ebuild
new file mode 100644
index 000000000000..eac0c38abbc9
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.22.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.22.ebuild,v 1.1 2007/03/11 21:20:37 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+SRC_URI="mirror://cpan/authors/id/P/PE/PETDANCE/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~petdance/"
+IUSE="test"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+# Bug in the tests - improper use of HTTP::Server
+#SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --mech-dump --nolive"
+
+
+DEPEND="dev-lang/perl
+ dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.76
+ >=dev-perl/URI-1.25
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Taint
+ dev-perl/Test-Warn
+ dev-perl/Test-Memory-Cycle )"
+