summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/namespace-clean/namespace-clean-0.18.ebuild')
-rw-r--r--dev-perl/namespace-clean/namespace-clean-0.18.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/namespace-clean/namespace-clean-0.18.ebuild b/dev-perl/namespace-clean/namespace-clean-0.18.ebuild
new file mode 100644
index 000000000000..787a59c3007a
--- /dev/null
+++ b/dev-perl/namespace-clean/namespace-clean-0.18.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/namespace-clean/namespace-clean-0.18.ebuild,v 1.1 2010/06/16 07:33:34 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=FLORA
+inherit perl-module
+
+DESCRIPTION="Keep imports and functions out of your namespace"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Package-Stash-0.03
+ >=dev-perl/Sub-Identify-0.04
+ >=dev-perl/Sub-Name-0.04
+ >=dev-perl/B-Hooks-EndOfScope-0.07"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31
+ test? ( >=virtual/perl-Test-Simple-0.88 )"
+
+SRC_TEST=do