summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Console_Getopt/ChangeLog10
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3.ebuild29
-rw-r--r--dev-php/PEAR-Console_Getopt/metadata.xml5
-rw-r--r--dev-php/PEAR-Structures_Graph/ChangeLog10
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild31
-rw-r--r--dev-php/PEAR-Structures_Graph/metadata.xml5
-rw-r--r--dev-php/PEAR-XML_Util/Manifest3
7 files changed, 92 insertions, 1 deletions
diff --git a/dev-php/PEAR-Console_Getopt/ChangeLog b/dev-php/PEAR-Console_Getopt/ChangeLog
new file mode 100644
index 000000000000..e46b8246f333
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php/PEAR-Console_Getopt
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Console_Getopt/ChangeLog,v 1.20 2009/09/23 02:46:59 beandog Exp $
+
+*PEAR-Console_Getopt-1.2.3 (23 Sep 2009)
+
+ 23 Sep 2009; Steve Dibb <beandog@gentoo.org>
+ +PEAR-Console_Getopt-1.2.3.ebuild, +metadata.xml:
+ Initial commit; new split ebuilds for PEAR base install
+
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3.ebuild
new file mode 100644
index 000000000000..32b28e232169
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3.ebuild,v 1.1 2009/09/23 02:46:59 beandog Exp $
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit depend.php
+
+DESCRIPTION="Command-line option parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Console_Getopt"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ require_php_with_use pcre
+}
+
+src_install() {
+ insinto /usr/share/php/
+ doins -r Console
+}
diff --git a/dev-php/PEAR-Console_Getopt/metadata.xml b/dev-php/PEAR-Console_Getopt/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/PEAR-Structures_Graph/ChangeLog b/dev-php/PEAR-Structures_Graph/ChangeLog
new file mode 100644
index 000000000000..0798a47daba2
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php/PEAR-Structures_Graph
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Structures_Graph/ChangeLog,v 1.1 2009/09/23 02:48:36 beandog Exp $
+
+*PEAR-Structures_Graph-1.0.2 (23 Sep 2009)
+
+ 23 Sep 2009; Steve Dibb <beandog@gentoo.org>
+ +PEAR-Structures_Graph-1.0.2.ebuild, +metadata.xml:
+ Initial commit; new split ebuilds for PEAR base install
+
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild
new file mode 100644
index 000000000000..16f551b938a3
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild,v 1.1 2009/09/23 02:48:36 beandog Exp $
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit depend.php
+
+DESCRIPTION="Graph datastructure manipulation library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Structures_Graph"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ require_php_with_use pcre
+}
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+
+ dohtml -r docs/html/*
+}
diff --git a/dev-php/PEAR-Structures_Graph/metadata.xml b/dev-php/PEAR-Structures_Graph/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/PEAR-XML_Util/Manifest b/dev-php/PEAR-XML_Util/Manifest
index 560790be5a6a..e46f0e6b8e55 100644
--- a/dev-php/PEAR-XML_Util/Manifest
+++ b/dev-php/PEAR-XML_Util/Manifest
@@ -3,6 +3,7 @@ DIST XML_Util-1.1.4.tgz 8576 RMD160 2087bde5920948deda81b3bab2ebfa438b194bbe SHA
DIST XML_Util-1.2.1.tgz 17729 RMD160 9d9dd43889312f46f39c9a43a800a8f2d8f6e9b2 SHA1 8072216577fb9ad684f15e0388ab0b1c0b57e2d4 SHA256 10edc563d20d6312cba41649e57e56b78b9330c486e9a8397fd5e109744e7273
EBUILD PEAR-XML_Util-1.1.1-r1.ebuild 444 RMD160 68067e387e01889eb4e8ac708d45dc160ba668a4 SHA1 3a7836e9a7d770df45147f09fccef26818243dec SHA256 5455e2910428e7148b617ca49026512fa4cb74cefed45a8ea02b8752a28ed49f
EBUILD PEAR-XML_Util-1.1.4.ebuild 442 RMD160 5974b4858ee8dd955ae1f22ff459c5b7c72d44b5 SHA1 7968c643cce7aa9cc4df23bc6ef5f7fb47650edb SHA256 02aab80f0e7a12a74fea823a2b5c5a648ef45278bf1e0d1fcc957dad57bc2070
+EBUILD PEAR-XML_Util-1.2.1-r1.ebuild 749 RMD160 1a037ae4c1a1ae7764dc8d55c573dded8345f27c SHA1 bdb546f51c868c43c909f933021049a01dc83cf5 SHA256 56a6e31c66588d627d2093da6228fb69d0ec93e6e9413144adfecfd5dd063b32
EBUILD PEAR-XML_Util-1.2.1.ebuild 453 RMD160 5dd079c7656dfd345a2165ca3b155a51a97b3cd0 SHA1 9819802e96eab7b72a87df9b00c903e54d039cc0 SHA256 3b5b22dc814654c578c78a1d781cad7d08f487ffca87999b09ea0ecdb8dada12
-MISC ChangeLog 4458 RMD160 154148eaa980c6a47ac91982706e5f444e0fb3eb SHA1 25878cba0450b8d10916d34d86658ab739ccec76 SHA256 37738d28a378a83dc489208aa7666cbebb08bb967120108a77fef4e86d3b68b0
+MISC ChangeLog 4616 RMD160 1563695712e52381058ddfa9aeb55e6ef2b44468 SHA1 6d4656a38e03ece4a686eec06d18d3532bd4dae7 SHA256 a2c2ef7e2b43dba7dcfac5f47ae713ef6dab66df289a94c90b49a8301be61182
MISC metadata.xml 156 RMD160 a3a59cdc3ac33d711123b2d7e2b1deb2984aa101 SHA1 1f452f476317b4634c684eabfd8840d06d35b414 SHA256 f6d70434415ff7294f2a64e7870f32318c5fab9153fe63a58841b12d897da6ba