summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/enable/enable-4.0.0.ebuild')
-rw-r--r--dev-python/enable/enable-4.0.0.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/enable/enable-4.0.0.ebuild b/dev-python/enable/enable-4.0.0.ebuild
deleted file mode 100644
index 3d934676c732..000000000000
--- a/dev-python/enable/enable-4.0.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.0.0.ebuild,v 1.4 2012/02/24 09:37:06 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: drawing and interaction packages"
-HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
-SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy
- dev-python/reportlab
- >=dev-python/traitsui-4.0
- >=media-libs/freetype-2
- virtual/opengl
- x11-libs/libX11"
-DEPEND="dev-python/setuptools
- dev-lang/swig
- dev-python/cython
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc
- )"
-
-DOCS="docs/*.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- VIRTUALX_COMMAND="distutils_src_test" virtualmake
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}