summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/formkit/formkit-0.6.1.ebuild')
-rw-r--r--dev-python/formkit/formkit-0.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/formkit/formkit-0.6.1.ebuild b/dev-python/formkit/formkit-0.6.1.ebuild
new file mode 100644
index 000000000000..584e769d30c1
--- /dev/null
+++ b/dev-python/formkit/formkit-0.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/formkit/formkit-0.6.1.ebuild,v 1.1 2004/10/23 12:16:02 satya Exp $
+
+inherit python distutils
+
+S=${WORKDIR}/FormKit
+DESCRIPTION="Library to handle server-side www forms. Written for Webware WebKit, it can be used stand-alone as well"
+SRC_URI="http://dalchemy.com/global/formkit-0.6.1.tar.bz2"
+HOMEPAGE="http://dalchemy.com/opensource/formkit/"
+
+DEPEND="dev-lang/python"
+
+IUSE=""
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+#DOCS="Docs/* Examples/*"
+
+src_compile() {
+ cp ${FILESDIR}/${PV}/setup.py . || die
+ #python setup.py build || die
+}
+
+src_install() {
+ python_version
+ distutils_src_install
+ dodoc License.txt
+ insinto /usr/share/doc/${PF}/Examples && doins Examples/*
+ insinto /usr/share/doc/${PF}/Docs && doins Docs/*
+}
+