summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/markupsafe/markupsafe-0.15.ebuild')
-rw-r--r--dev-python/markupsafe/markupsafe-0.15.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/markupsafe/markupsafe-0.15.ebuild b/dev-python/markupsafe/markupsafe-0.15.ebuild
deleted file mode 100644
index d4e930bc4a7b..000000000000
--- a/dev-python/markupsafe/markupsafe-0.15.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/markupsafe/markupsafe-0.15.ebuild,v 1.13 2012/05/09 00:11:59 aballier Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-MY_PN="MarkupSafe"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Implements a XML/HTML/XHTML Markup safe string for Python"
-HOMEPAGE="http://pypi.python.org/pypi/MarkupSafe"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-set_global_options() {
- if [[ "$(python_get_implementation)" = "CPython" ]]; then
- DISTUTILS_GLOBAL_OPTIONS=("--with-speedups")
- else
- DISTUTILS_GLOBAL_OPTIONS=()
- fi
-}
-
-distutils_src_compile_pre_hook() {
- set_global_options
-}
-
-distutils_src_test_pre_hook() {
- set_global_options
-}
-
-distutils_src_install_pre_hook() {
- set_global_options
-}
-
-src_install() {
- distutils_src_install
- python_clean_installation_image
-}