summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/psutil/psutil-1.2.1.ebuild')
-rw-r--r--dev-python/psutil/psutil-1.2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/psutil/psutil-1.2.1.ebuild b/dev-python/psutil/psutil-1.2.1.ebuild
new file mode 100644
index 000000000000..460d1612956b
--- /dev/null
+++ b/dev-python/psutil/psutil-1.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/psutil-1.2.1.ebuild,v 1.1 2013/11/25 22:27:52 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="http://code.google.com/p/psutil/ https://pypi.python.org/pypi/psutil/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}