summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycparser/pycparser-2.09.1.ebuild')
-rw-r--r--dev-python/pycparser/pycparser-2.09.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pycparser/pycparser-2.09.1.ebuild b/dev-python/pycparser/pycparser-2.09.1.ebuild
new file mode 100644
index 000000000000..7605e202d2ac
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.09.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycparser/pycparser-2.09.1.ebuild,v 1.1 2013/01/08 02:51:30 radhermit Exp $
+
+EAPI="5"
+# 3.3 not supported due to nose lacking support
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="https://bitbucket.org/eliben/pycparser/"
+SRC_URI="https://bitbucket.org/eliben/${PN}/get/release_v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/ply"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die
+}