summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/root_numpy/root_numpy-2.1.0.ebuild')
-rw-r--r--dev-python/root_numpy/root_numpy-2.1.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/root_numpy/root_numpy-2.1.0.ebuild b/dev-python/root_numpy/root_numpy-2.1.0.ebuild
index caa79617e9bc..8c1c9a354951 100644
--- a/dev-python/root_numpy/root_numpy-2.1.0.ebuild
+++ b/dev-python/root_numpy/root_numpy-2.1.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/root_numpy/root_numpy-2.1.0.ebuild,v 1.1 2013/08/12 17:12:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/root_numpy/root_numpy-2.1.0.ebuild,v 1.2 2013/09/17 07:33:45 mgorny Exp $
EAPI=5
+DISTUTILS_SINGLE_IMPL=1
PYTHON_COMPAT=( python{2_6,2_7} )
inherit distutils-r1
@@ -19,20 +20,17 @@ IUSE="examples test"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
- sci-physics/root[${PYTHON_USEDEP}]"
+ sci-physics/root[python,${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
cd ${BUILD_DIR} || die
- nosetests-${EPYTHON} -v || die "Testing failed with ${EPYTHON}"
+ nosetests -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
+ use examples && local EXAMPLES=( tutorial/. )
distutils-r1_python_install_all
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r tutorial/*
- fi
}