summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webob/webob-1.0.5.ebuild')
-rw-r--r--dev-python/webob/webob-1.0.5.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/webob/webob-1.0.5.ebuild b/dev-python/webob/webob-1.0.5.ebuild
deleted file mode 100644
index 513c1a937fe3..000000000000
--- a/dev-python/webob/webob-1.0.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.5.ebuild,v 1.2 2011/03/26 19:26:12 klausman Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN="WebOb"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://pythonpaste.org/webob/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-# Tests depend on some packages absent in the tree.
-DEPEND="app-arch/unzip
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd build/sphinx/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}