summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/workingenv/workingenv-0.6.5.ebuild')
-rw-r--r--dev-python/workingenv/workingenv-0.6.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/workingenv/workingenv-0.6.5.ebuild b/dev-python/workingenv/workingenv-0.6.5.ebuild
new file mode 100644
index 000000000000..7b08d062b5ba
--- /dev/null
+++ b/dev-python/workingenv/workingenv-0.6.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/workingenv/workingenv-0.6.5.ebuild,v 1.1 2007/04/21 23:34:24 pythonhead Exp $
+
+inherit distutils
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool to create an isolated Python environment."
+HOMEPAGE="http://svn.colorstudy.com/home/ianb/workingenv/"
+SRC_URI="http://cheeseshop.python.org/packages/source/w/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S=${WORKDIR}/${MY_P}
+
+pkg_postinst() {
+ einfo "Quickstart:"
+ einfo ""
+ einfo "workingenv <directory name>"
+ einfo "source <directory name>/bin/activate"
+ einfo ""
+ einfo "You are now working in a sandboxed Python environment."
+ einfo "Any packages installed with distutils/easy_install/setuptools"
+ einfo "will be installed in <directory name>/lib"
+ einfo "Note: <directory name> will be created."
+}