summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtcore/qtcore-4.8.5.ebuild')
-rw-r--r--dev-qt/qtcore/qtcore-4.8.5.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-qt/qtcore/qtcore-4.8.5.ebuild b/dev-qt/qtcore/qtcore-4.8.5.ebuild
index 4549ebae743c..d2b8df68644b 100644
--- a/dev-qt/qtcore/qtcore-4.8.5.ebuild
+++ b/dev-qt/qtcore/qtcore-4.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtcore/qtcore-4.8.5.ebuild,v 1.2 2013/07/10 05:07:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtcore/qtcore-4.8.5.ebuild,v 1.3 2013/07/10 09:02:41 pesa Exp $
EAPI=5
@@ -27,10 +27,9 @@ PDEPEND="
qt3support? ( ~dev-qt/qtgui-${PV}[aqua=,debug=,glib=,qt3support] )
"
-# Doesn't apply, partially present in the source. Check if obsolete.
-#PATCHES=(
-# "${FILESDIR}/moc-workaround-for-BOOST_JOIN.patch"
-#)
+PATCHES=(
+ "${FILESDIR}/moc-boost-lexical-cast.patch"
+)
pkg_setup() {
QT4_TARGET_DIRECTORIES="
@@ -47,13 +46,7 @@ pkg_setup() {
tools/linguist/lupdate"
QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- include/Qt
- include/QtCore
- include/QtDeclarative
- include/QtGui
- include/QtNetwork
- include/QtScript
- include/QtXml
+ include
src/plugins/plugins.pro
src/plugins/qpluginbase.pri
src/src.pro