summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activerecord/activerecord-4.2.1.ebuild')
-rw-r--r--dev-ruby/activerecord/activerecord-4.2.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/activerecord/activerecord-4.2.1.ebuild b/dev-ruby/activerecord/activerecord-4.2.1.ebuild
index 1daf6ba6112a..d8071cb1239a 100644
--- a/dev-ruby/activerecord/activerecord-4.2.1.ebuild
+++ b/dev-ruby/activerecord/activerecord-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.2.1.ebuild,v 1.1 2015/03/19 19:25:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.2.1.ebuild,v 1.2 2015/06/09 14:39:00 mrueg Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
@@ -22,14 +22,14 @@ SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE="mysql postgres sqlite3"
+IUSE="mysql postgres sqlite"
RUBY_S="rails-${PV}/${PN}"
ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
>=dev-ruby/arel-6.0:6.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.6 )
+ sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
mysql? ( >=dev-ruby/mysql2-0.3.13:0.3 )
postgres? ( >=dev-ruby/pg-0.15.0 )"
@@ -68,7 +68,7 @@ all_ruby_prepare() {
}
each_ruby_test() {
- if use sqlite3; then
+ if use sqlite; then
${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
fi
}