summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/amatch/amatch-0.2.3.ebuild')
-rw-r--r--dev-ruby/amatch/amatch-0.2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/amatch/amatch-0.2.3.ebuild b/dev-ruby/amatch/amatch-0.2.3.ebuild
new file mode 100644
index 000000000000..1fc07ed1cbb9
--- /dev/null
+++ b/dev-ruby/amatch/amatch-0.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/amatch-0.2.3.ebuild,v 1.1 2009/07/14 17:54:26 graaff Exp $
+
+inherit ruby
+
+USE_RUBY="ruby18"
+
+DESCRIPTION="A template library for ruby like amrita"
+HOMEPAGE="http://amatch.rubyforge.org"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="virtual/ruby"
+
+src_compile() {
+ ruby install.rb config || die 'install.rb config failed'
+ ruby install.rb setup || die 'install.rb setup failed'
+}
+
+src_install() {
+ ruby install.rb config --prefix="${D}"/usr || die 'install.rb config failed'
+ ruby install.rb install || die 'install.rb install failed'
+ dodoc README.en
+}