summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/wxglade/wxglade-0.3.5.1.ebuild')
-rw-r--r--dev-util/wxglade/wxglade-0.3.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/wxglade/wxglade-0.3.5.1.ebuild b/dev-util/wxglade/wxglade-0.3.5.1.ebuild
new file mode 100644
index 000000000000..e1cd4dbf81b7
--- /dev/null
+++ b/dev-util/wxglade/wxglade-0.3.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.3.5.1.ebuild,v 1.1 2004/11/08 18:57:29 pythonhead Exp $
+
+inherit python
+
+MY_P="wxGlade-${PV}"
+DESCRIPTION="Glade-like GUI designer which can generate Python, Perl, C++ or XRC code"
+HOMEPAGE="http://wxglade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxglade/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+DEPEND=">=dev-lang/python-2.2
+ app-arch/unzip
+ >=dev-python/wxpython-2.4.2.4"
+
+src_install() {
+ python_version
+ dodir /usr/lib/python${PYVER}/site-packages/${PN}
+ dodoc *txt
+ cp credits.txt ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
+ dohtml -r docs/*
+ rm -rf docs *txt
+ cp -R * ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
+ dosym /usr/share/doc/${PF}/html /usr/lib/python${PYVER}/site-packages/${PN}/docs
+ echo "#!/bin/bash" > wxglade
+ echo "exec python /usr/lib/python${PYVER}/site-packages/${PN}/wxglade.py \$*" >> wxglade
+ exeinto /usr/bin
+ doexe wxglade
+}
+