summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/aegis/ChangeLog7
-rw-r--r--dev-util/aegis/aegis-4.9.ebuild69
-rw-r--r--dev-util/aegis/files/digest-aegis-4.91
-rw-r--r--dev-util/fhist/ChangeLog7
-rw-r--r--dev-util/fhist/fhist-1.10.ebuild38
-rw-r--r--dev-util/fhist/files/digest-fhist-1.101
6 files changed, 121 insertions, 2 deletions
diff --git a/dev-util/aegis/ChangeLog b/dev-util/aegis/ChangeLog
index 9e13498c3362..58d36bd2a721 100644
--- a/dev-util/aegis/ChangeLog
+++ b/dev-util/aegis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/aegis
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/ChangeLog,v 1.3 2002/10/19 00:56:51 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/ChangeLog,v 1.4 2002/11/05 19:29:05 aliz Exp $
+
+*aegis-4.9 (05 Nov 2002)
+
+ 05 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
*aegis-4.7 (19 Oct 2002)
diff --git a/dev-util/aegis/aegis-4.9.ebuild b/dev-util/aegis/aegis-4.9.ebuild
new file mode 100644
index 000000000000..43baff3390b9
--- /dev/null
+++ b/dev-util/aegis/aegis-4.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/aegis-4.9.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+
+IUSE="tcltk"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A transaction based revision control system"
+SRC_URI="http://aegis.sourceforge.net/${P}.tar.gz"
+HOMEPAGE="http://aegis.sourceforge.net"
+
+DEPEND="sys-libs/zlib
+ sys-devel/gettext
+ sys-apps/groff
+ sys-devel/bison
+ tcltk? ( >=dev-lang/tk-8.3 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~sparc64"
+
+src_compile() {
+ # By default aegis configure puts shareable read/write files (locks etc)
+ # in ${prefix}/com/aegis but the FHS says /var/lib/aegis can be shared.
+
+ myconf="${myconf} --with-nlsdir=/usr/share/locale"
+
+ econf \
+ --sharedstatedir=/var/lib/aegis \
+ ${myconf} || die "./configure failed"
+
+ # Second ebuild causes redefined/undefined function errors
+ make clean
+
+ # not emake safe, I think
+ make || die
+}
+
+src_install () {
+ make RPM_BUILD_ROOT=${D} install || die
+
+ # Alas gentoo appears to have no profile.d mechanism, so:
+ rm ${D}/etc/profile.d/aegis.sh
+ rm ${D}/etc/profile.d/aegis.csh
+ rmdir ${D}/etc/profile.d
+ rmdir ${D}/etc
+
+ # OK so ${D}/var/lib/aegis gets UID=3, but for some
+ # reason so do the files under /usr/share, even though
+ # they are read-only.
+ chown -R root.root ${D}/usr/share
+
+ # Remove duplicate documention etc.
+ rm -r ${D}/usr/share/aegis/en
+ rm -r ${D}/usr/share/aegis/de
+ rm -r ${D}/usr/share/aegis/man1
+
+ # Leaving out the .dvi versions and junk.
+ dodoc lib/en/*.txt
+ dodoc lib/en/*.ps
+
+ # Link to share dir so user has a chance of noticing it.
+ dosym /usr/share/aegis /usr/share/doc/${PF}/scripts
+
+ # Config file examples are documentation.
+ mv ${D}/usr/share/aegis/config.example ${D}/usr/share/doc/${PF}/
+
+ dodoc LICENSE BUILDING MANIFEST README
+}
diff --git a/dev-util/aegis/files/digest-aegis-4.9 b/dev-util/aegis/files/digest-aegis-4.9
new file mode 100644
index 000000000000..2d1bbf258592
--- /dev/null
+++ b/dev-util/aegis/files/digest-aegis-4.9
@@ -0,0 +1 @@
+MD5 8c98e1b423d06057589b8c6712e12478 aegis-4.9.tar.gz 2249148
diff --git a/dev-util/fhist/ChangeLog b/dev-util/fhist/ChangeLog
index 4b807678606f..ad3ee78e160b 100644
--- a/dev-util/fhist/ChangeLog
+++ b/dev-util/fhist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/fhist
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/fhist/ChangeLog,v 1.1 2002/04/13 21:10:35 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fhist/ChangeLog,v 1.2 2002/11/05 19:29:05 aliz Exp $
+
+*fhist-1.10 (05 Nov 2002)
+
+ 05 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
*fhist-1.8 (13 Apr 2002)
diff --git a/dev-util/fhist/fhist-1.10.ebuild b/dev-util/fhist/fhist-1.10.ebuild
new file mode 100644
index 000000000000..94737aa5ae4f
--- /dev/null
+++ b/dev-util/fhist/fhist-1.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fhist/fhist-1.10.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="File history and comparison tools"
+SRC_URI="http://www.canb.auug.org.au/~millerp/${P}.tar.gz"
+HOMEPAGE="http://www.canb.auug.org.au/~millerp/fhist.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~sparc64"
+
+DEPEND="sys-devel/gettext
+ sys-apps/groff
+ sys-devel/bison"
+
+src_compile() {
+ econf || die "./configure failed"
+ make clean
+ make || die
+}
+
+src_install () {
+ make RPM_BUILD_ROOT=${D} install || die
+
+ dodoc lib/en/*.txt
+ dodoc lib/en/*.ps
+
+ # remove duplicate docs etc.
+ rm -r ${D}/usr/share/fhist
+
+ # move message catalogs into the usual gentoo place
+ dodir /usr/share/locale
+ mv ${D}/usr/lib/fhist/en ${D}/usr/share/locale/
+
+ dodoc LICENSE MANIFEST README
+}
diff --git a/dev-util/fhist/files/digest-fhist-1.10 b/dev-util/fhist/files/digest-fhist-1.10
new file mode 100644
index 000000000000..226a1101c45d
--- /dev/null
+++ b/dev-util/fhist/files/digest-fhist-1.10
@@ -0,0 +1 @@
+MD5 56ef902903a21d8a1b3f88db13bc0571 fhist-1.10.tar.gz 246369