summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/cgoban2/cgoban2-2.6.1.ebuild')
-rw-r--r--games-board/cgoban2/cgoban2-2.6.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-board/cgoban2/cgoban2-2.6.1.ebuild b/games-board/cgoban2/cgoban2-2.6.1.ebuild
new file mode 100644
index 000000000000..38ee8d0e159b
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/cgoban2/cgoban2-2.6.1.ebuild,v 1.1 2004/05/27 22:31:33 mr_bones_ Exp $
+
+inherit games
+
+S="${WORKDIR}/cgoban"
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://kgs.kiseido.com/"
+SRC_URI="http://kgs.kiseido.com/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.3
+ virtual/x11"
+
+src_install() {
+ dodir ${GAMES_BINDIR} || die "dodir failed"
+ sed -e "s:INSTALL_DIR:${GAMES_DATADIR}/${PN}:" \
+ ${FILESDIR}/${PN} > ${D}${GAMES_BINDIR}/${PN} || \
+ die "sed failed"
+ insinto ${GAMES_DATADIR}/${PN}
+ doins cgoban.jar || die "doins failed"
+ prepgamesdirs
+}