summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/mmucl/mmucl-1.5.2.ebuild')
-rw-r--r--games-mud/mmucl/mmucl-1.5.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-mud/mmucl/mmucl-1.5.2.ebuild b/games-mud/mmucl/mmucl-1.5.2.ebuild
new file mode 100644
index 000000000000..2108f9ef8d26
--- /dev/null
+++ b/games-mud/mmucl/mmucl-1.5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mmucl/mmucl-1.5.2.ebuild,v 1.1 2004/08/25 05:59:29 cardoe Exp $
+
+inherit games
+
+DESCRIPTION="Marks Mud CLient - A mud client written completely in tcl/tk"
+HOMEPAGE="http://mmucl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mmucl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="readline"
+
+RDEPEND=">=dev-lang/tk-8.4
+ readline? ( dev-tcltk/tclreadline )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "/^BASE_DIR/ s:=.*:=/usr:" \
+ -e "/^BIN_DIR/ s:=.*:=${GAMES_BINDIR}:" \
+ -e "/^LIB_DIR/ s:=.*:=${GAMES_LIBDIR}/${PN}:" \
+ -e "" "${S}/Makefile" \
+ || die "sed Makefile failed"
+}
+
+src_install () {
+ local LIBDIR="${GAMES_LIBDIR}/${PN}"
+
+ dogamesbin mmucl2 || die "dogamesbin failed"
+ insinto ${LIBDIR}/lib
+ doins lib/*.tcl || die "doins failed (lib)"
+ insinto ${LIBDIR}/images
+ doins images/*.gif || die "doins failed (images)"
+ insinto ${LIBDIR}/interface
+ doins interface/*.tcl || die "doins failed (interface)"
+ insinto ${LIBDIR}/script
+ doins script/*.{tcl,rc} || die "doins failed (script)"
+ insinto ${LIBDIR}/script/contrib
+ doins script/contrib/* || die "doins failed (contrib)"
+ insinto ${LIBDIR}/test
+ doins test/*.test || die "doins failed (test)"
+ doinfo mmucl.info || die "doinfo failed"
+ dodoc CHANGES TODO INSTALL README || die "dodoc failed"
+ dohtml mmucl.html || die "dohtml failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "You must be in the 'games' group to run this application."
+ einfo "The executable for this is mmucl2."
+}