summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/londonlaw/files')
-rw-r--r--games-puzzle/londonlaw/files/digest-londonlaw-0.2.01
-rw-r--r--games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/londonlaw/files/digest-londonlaw-0.2.0 b/games-puzzle/londonlaw/files/digest-londonlaw-0.2.0
new file mode 100644
index 000000000000..0dfbaa97ef74
--- /dev/null
+++ b/games-puzzle/londonlaw/files/digest-londonlaw-0.2.0
@@ -0,0 +1 @@
+MD5 c24fa28338d748783204df1f2eb2f16e londonlaw-0.2.0.tar.gz 3190143
diff --git a/games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch b/games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch
new file mode 100644
index 000000000000..eef8059850bf
--- /dev/null
+++ b/games-puzzle/londonlaw/files/londonlaw-0.2.0-setup.py.patch
@@ -0,0 +1,37 @@
+--- setup.py 2005-02-18 04:51:06.000000000 +0100
++++ setup.py.1 2005-02-20 22:51:31.687411720 +0100
+@@ -10,20 +10,14 @@
+ # Read off the PREFIX value, so we can tell jools where to find its
+ # data files (FIXME: is there a clean way to handle this through distutils?
+ if 'sdist' not in sys.argv and 'clean' not in sys.argv:
+- PREFIX=os.path.normpath(sys.prefix) # default
++ DATA_PREFIX="" # default
+ for arg in sys.argv:
+- index = string.find(arg, "--prefix=")
++ index = string.find(arg, "--install-data=")
+ if index > -1:
+- PREFIX = os.path.normpath(arg[(index+len("--prefix=")):])
+-
+- ROOT = "/" # default
+- for arg in sys.argv:
+- index = string.find(arg, "--root=")
+- if index > -1:
+- ROOT = os.path.normpath(arg[(index+len("--root=")):])
++ DATA_PREFIX = os.path.normpath(arg[(index+len("--install-data=")):])
+
+ config = open("londonlaw/common/config.py", "w")
+- config.write("MEDIAROOT = \"" + os.path.join(PREFIX,"share/londonlaw/guiclient") + "\"\n")
++ config.write("MEDIAROOT = \"" + os.path.join(DATA_PREFIX,"londonlaw/guiclient") + "\"\n")
+ config.close()
+
+
+@@ -37,7 +31,8 @@
+ if os.path.isfile(fullFile):
+ newFiles.append(fullFile)
+ if newFiles != []:
+- installList.append( (os.path.join('share', dirname), newFiles) )
++# installList.append( (os.path.join('share', dirname), newFiles) )
++ installList.append( (dirname, newFiles) )
+
+
+ # Get all data files by walking through the proper directory trees