summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/manaplus/manaplus-1.3.4.14.ebuild')
-rw-r--r--games-rpg/manaplus/manaplus-1.3.4.14.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-rpg/manaplus/manaplus-1.3.4.14.ebuild b/games-rpg/manaplus/manaplus-1.3.4.14.ebuild
new file mode 100644
index 000000000000..11294dc23cef
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.3.4.14.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/manaplus-1.3.4.14.ebuild,v 1.1 2013/04/13 20:46:28 hasufell Exp $
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/libpng:0
+ media-fonts/dejavu
+ >=dev-games/guichan-0.8.1[sdl]
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-misc/xsel
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/^SUBDIRS/s/fonts//' \
+ data/Makefile.in || die
+
+ rm -r src/guichan || die
+}
+
+src_configure() {
+ egamesconf \
+ --without-internalguichan \
+ --localedir=/usr/share/locale \
+ --disable-manaserv \
+ --disable-eathena \
+ $(use_with opengl) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-mono.ttf
+ insinto "${GAMES_DATADIR}"/${PN}/data
+
+ prepgamesdirs
+}