summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kaddressbook/kaddressbook-3.4.1.ebuild')
-rw-r--r--kde-base/kaddressbook/kaddressbook-3.4.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/kde-base/kaddressbook/kaddressbook-3.4.1.ebuild b/kde-base/kaddressbook/kaddressbook-3.4.1.ebuild
new file mode 100644
index 000000000000..a13a465a8671
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-3.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.4.1.ebuild,v 1.1 2005/05/25 21:23:00 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+OLDDEPEND="~kde-base/libkdepim-$PV
+ ~kde-base/libkcal-$PV
+ ~kde-base/certmanager-$PV
+ ~kde-base/libkdenetwork-$PV
+ ~kde-base/kontact-$PV"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/certmanager)
+$(deprange $PV $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/kontact)"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkcal libkcal
+ libkleopatra certmanager/lib/
+ libqgpgme libkdenetwork/qgpgme/
+ libkpinterfaces kontact/interfaces/"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ libkcal/
+ libical/
+ certmanager/
+ kontact/interfaces/
+ akregator
+ kmail/kmailIface.h"
+KMCOMPILEONLY="
+ libical/src/libical/
+ libical/src/libicalss/
+ akregator/src/librss"
+ # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
+KMEXTRA="
+ kabc/
+ kfile-plugins/vcf
+ kontact/plugins/kaddressbook"
+
+src_compile() {
+ export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd ${S}/libical/src/libical && make ical.h
+ # generate "icalss.h"
+ cd ${S}/libical/src/libicalss && make icalss.h
+
+ kde-meta_src_compile "make"
+}