summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kate/kate-4.3.0.ebuild')
-rw-r--r--kde-base/kate/kate-4.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/kate/kate-4.3.0.ebuild b/kde-base/kate/kate-4.3.0.ebuild
new file mode 100644
index 000000000000..876bc19908fd
--- /dev/null
+++ b/kde-base/kate/kate-4.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.3.0.ebuild,v 1.1 2009/08/03 23:55:14 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kate-plugins"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with plasma)"
+
+ kde4-meta_src_configure
+}