summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdesktop')
-rw-r--r--kde-base/kdesktop/ChangeLog8
-rw-r--r--kde-base/kdesktop/files/digest-kdesktop-3.5.86
-rw-r--r--kde-base/kdesktop/kdesktop-3.5.8.ebuild59
3 files changed, 72 insertions, 1 deletions
diff --git a/kde-base/kdesktop/ChangeLog b/kde-base/kdesktop/ChangeLog
index 621bf4f8bb52..e52e3ea52557 100644
--- a/kde-base/kdesktop/ChangeLog
+++ b/kde-base/kdesktop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdesktop
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.99 2007/08/11 16:38:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.100 2007/10/19 22:43:49 philantrop Exp $
+
+*kdesktop-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdesktop-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org> kdesktop-3.5.7.ebuild:
x86 stable wrt #185823
diff --git a/kde-base/kdesktop/files/digest-kdesktop-3.5.8 b/kde-base/kdesktop/files/digest-kdesktop-3.5.8
new file mode 100644
index 000000000000..3036d71a1afc
--- /dev/null
+++ b/kde-base/kdesktop/files/digest-kdesktop-3.5.8
@@ -0,0 +1,6 @@
+MD5 da0b6ef72a164f0a1af0943ef045ed17 kdebase-3.5-patchset-05.tar.bz2 16068
+RMD160 dc1572fbb3cf3ce9a8e424edd3408b8912c6bfd5 kdebase-3.5-patchset-05.tar.bz2 16068
+SHA256 d1d3c8b51c68610c76c61ba4923618a16609bb76af547d8d26bb9a3f6990bd4d kdebase-3.5-patchset-05.tar.bz2 16068
+MD5 10950c172c1d9529c621a000c6b39d10 kdebase-3.5.8.tar.bz2 2501632
+RMD160 718e72b4b990eea04763298cadae9e7103ae1808 kdebase-3.5.8.tar.bz2 2501632
+SHA256 90f5070737c638c3a0cbce416ae2cfd471140ca4108056c8f8a3449b951f22dd kdebase-3.5.8.tar.bz2 2501632
diff --git a/kde-base/kdesktop/kdesktop-3.5.8.ebuild b/kde-base/kdesktop/kdesktop-3.5.8.ebuild
new file mode 100644
index 000000000000..9a589d362d0c
--- /dev/null
+++ b/kde-base/kdesktop/kdesktop-3.5.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.8.ebuild,v 1.1 2007/10/19 22:43:49 philantrop Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-05.tar.bz2"
+
+DESCRIPTION="KDesktop is the KDE interface that handles the icons, desktop popup menus and the screensaver system."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xscreensaver"
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkonq)
+ $(deprange $PV $MAXKDEVER kde-base/kcontrol)
+ xscreensaver? ( x11-proto/scrnsaverproto )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+ $(deprange $PV $MAXKDEVER kde-base/kcheckpass)
+ $(deprange 3.5.5 $MAXKDEVER kde-base/kdialog)
+ $(deprange $PV $MAXKDEVER kde-base/konqueror)
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+
+KMCOPYLIB="libkonq libkonq/"
+KMEXTRACTONLY="kcheckpass/kcheckpass.h
+ libkonq/
+ kdm/kfrontend/themer/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background
+ kdmlib/"
+KMNODOCS=true
+
+src_unpack() {
+ kde-meta_src_unpack
+ # see bug #143375
+ sed -e "s:SUBDIRS = . lock pics patterns programs init:SUBDIRS = . lock pics patterns programs:" \
+ -i kdesktop/Makefile.am
+}
+src_compile() {
+ myconf="${myconf} $(use_with xscreensaver)"
+ kde-meta_src_compile
+}
+
+src_install() {
+ # ugly, needs fixing: don't install kcontrol/background
+ kde-meta_src_install
+
+ rmdir "${D}/${PREFIX}/share/templates/.source/emptydir"
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+ mkdir -p "${PREFIX}/share/templates/.source/emptydir"
+}