summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kpilot/kpilot-3.4.1.ebuild')
-rw-r--r--kde-base/kpilot/kpilot-3.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-base/kpilot/kpilot-3.4.1.ebuild b/kde-base/kpilot/kpilot-3.4.1.ebuild
new file mode 100644
index 000000000000..6b13d9a54124
--- /dev/null
+++ b/kde-base/kpilot/kpilot-3.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.4.1.ebuild,v 1.1 2005/05/25 21:23:10 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KPilot - HotSync software for KDE"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="app-pda/pilot-link
+ dev-libs/libmal
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/kontact)"
+
+KMCOPYLIB="
+ libkcal libkcal
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/
+ libkdepim libkdepim/
+ kontact/interfaces/"
+KMEXTRA="
+ kfile-plugins/palm-databases
+ kontact/plugins/kpilot/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_compile() {
+ # needed to detect pi-notepad.h, used by the kpilot notepad conduit.
+ myconf="${myconf} --with-extra-includes=/usr/include/libpisock"
+
+ kde-meta_src_compile
+}