summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ktux/ktux-4.4.3.ebuild')
-rw-r--r--kde-base/ktux/ktux-4.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/ktux/ktux-4.4.3.ebuild b/kde-base/ktux/ktux-4.4.3.ebuild
new file mode 100644
index 000000000000..d73dc426c4ef
--- /dev/null
+++ b/kde-base/ktux/ktux-4.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ktux-4.4.3.ebuild,v 1.1 2010/05/03 21:25:58 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdetoys"
+inherit kde4-meta
+
+DESCRIPTION="KDE: screensaver featuring the Space-Faring Tux"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+# libkworkspace - only as a stub to provide KDE4Workspace config
+DEPEND="
+ $(add_kdebase_dep kscreensaver)
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e's/${KDE4WORKSPACE_KSCREENSAVER_LIBRARY}/kscreensaver/' \
+ "${PN}"/CMakeLists.txt || die "Failed to patch CMakeLists.txt"
+
+ kde4-meta_src_prepare
+}