summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kwin/kwin-4.2.4.ebuild')
-rw-r--r--kde-base/kwin/kwin-4.2.4.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/kde-base/kwin/kwin-4.2.4.ebuild b/kde-base/kwin/kwin-4.2.4.ebuild
deleted file mode 100644
index 4e15a7b2eaa9..000000000000
--- a/kde-base/kwin/kwin-4.2.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.2.4.ebuild,v 1.2 2009/06/05 07:31:20 alexxy Exp $
-
-EAPI="2"
-
-KMNAME="kdebase-workspace"
-OPENGL_REQUIRED="optional"
-inherit kde4-meta
-
-DESCRIPTION="KDE window manager"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="debug captury xcomposite xinerama"
-
-COMMONDEPEND="
- >=kde-base/kephal-${PV}:${SLOT}[kdeprefix=]
- x11-libs/libXdamage
- x11-libs/libXfixes
- >=x11-libs/libXrandr-1.2.1
- x11-libs/libXrender
- captury? ( media-libs/libcaptury )
- opengl? ( virtual/opengl )
- xcomposite? ( x11-libs/libXcomposite )
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="${COMMONDEPEND}
- x11-proto/damageproto
- x11-proto/renderproto
- xcomposite? ( x11-proto/compositeproto )
- xinerama? ( x11-proto/xineramaproto )
-"
-RDEPEND="${COMMONDEPEND}"
-
-src_prepare() {
- if ! use captury; then
- sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
- -i "${S}"/kwin/effects/CMakeLists.txt || \
- die "Making captury optional failed."
- fi
-
- kde4-meta_src_prepare
-}
-
-src_configure() {
- mycmakeargs="${mycmakeargs}
- $(cmake-utils_use_with opengl OpenGL)"
-
- kde4-meta_src_configure
-}