summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/noatun-plugins/noatun-plugins-3.4.1.ebuild')
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.4.1.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.4.1.ebuild
new file mode 100644
index 000000000000..249de2e301d3
--- /dev/null
+++ b/kde-base/noatun-plugins/noatun-plugins-3.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.4.1.ebuild,v 1.1 2005/05/25 21:23:14 danarmak Exp $
+KMNAME=kdeaddons
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Various plugins for noatun"
+KEYWORDS="~x86 ~amd64"
+IUSE="arts sdl berkdb"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/noatun)
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ berkdb? ( =sys-libs/db-4.2* )"
+
+# This patch makes the configure test in noatun-oblique find db_cxx.h,
+# but it also makes db support non-optional. should be fixed, ideally
+if useq berkdb; then
+ PATCHES="$FILESDIR/noatun-oblique-db-location-3.4.0_rc1.diff"
+ myconf="--with-extra-includes=/usr/include/db4.2"
+fi
+