summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/qtruby/qtruby-3.5.8.ebuild')
-rw-r--r--kde-base/qtruby/qtruby-3.5.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/qtruby/qtruby-3.5.8.ebuild b/kde-base/qtruby/qtruby-3.5.8.ebuild
new file mode 100644
index 000000000000..f40e766efaf0
--- /dev/null
+++ b/kde-base/qtruby/qtruby-3.5.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-3.5.8.ebuild,v 1.1 2007/10/19 23:57:49 philantrop Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Ruby bindings for QT"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=" >=virtual/ruby-1.8
+$(deprange 3.5.6 $MAXKDEVER kde-base/smoke)"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke versions.
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}