summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.6.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 890d02550464..169757acfc46 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.75 2011/06/10 11:50:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.76 2011/06/10 18:00:13 dilfridge Exp $
+
+*step-4.6.4 (10 Jun 2011)
+
+ 10 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> +step-4.6.4.ebuild:
+ Version bump
10 Jun 2011; Markos Chandras <hwoarang@gentoo.org> step-4.6.3.ebuild:
Stable on amd64 wrt bug #369979
diff --git a/kde-base/step/step-4.6.4.ebuild b/kde-base/step/step-4.6.4.ebuild
new file mode 100644
index 000000000000..022106aaed6e
--- /dev/null
+++ b/kde-base/step/step-4.6.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.6.4.ebuild,v 1.1 2011/06/10 18:00:13 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeedu"
+ kde_eclass="kde4-meta"
+fi
+
+inherit ${kde_eclass}
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+ ${kde_eclass}_src_configure
+}