summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/msmtp/msmtp-1.4.20.ebuild')
-rw-r--r--mail-mta/msmtp/msmtp-1.4.20.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/mail-mta/msmtp/msmtp-1.4.20.ebuild b/mail-mta/msmtp/msmtp-1.4.20.ebuild
index a740902b1d33..630bc778975e 100644
--- a/mail-mta/msmtp/msmtp-1.4.20.ebuild
+++ b/mail-mta/msmtp/msmtp-1.4.20.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.20.ebuild,v 1.1 2010/06/09 18:51:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.20.ebuild,v 1.2 2010/07/12 17:33:09 ssuominen Exp $
EAPI=2
+inherit eutils
DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
HOMEPAGE="http://msmtp.sourceforge.net/"
@@ -32,7 +33,11 @@ DEPEND="${DEPEND}
PROVIDE="mta? ( virtual/mta )"
-src_configure () {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openssl-1.patch
+}
+
+src_configure() {
local myconf
if use gnutls ; then
@@ -51,7 +56,7 @@ src_configure () {
${myconf}
}
-src_install () {
+src_install() {
emake DESTDIR="${D}" install || die "install failed"
if use mta; then