summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/msmtp/msmtp-1.4.9.ebuild')
-rw-r--r--mail-mta/msmtp/msmtp-1.4.9.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/mail-mta/msmtp/msmtp-1.4.9.ebuild b/mail-mta/msmtp/msmtp-1.4.9.ebuild
new file mode 100644
index 000000000000..9ebf017f7c52
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.4.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.9.ebuild,v 1.1 2006/12/20 18:07:14 slarti Exp $
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="http://msmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/msmtp/${P}.tar.bz2"
+LICENSE="GPL-2"
+IUSE="ssl gnutls sasl mailwrapper doc nls"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ sasl? ( >=virtual/gsasl-0.2.4 )
+ nls? ( sys-devel/gettext )"
+RDEPEND="mailwrapper? ( >=net-mail/mailwrapper-0.2 )
+ !mailwrapper? ( !virtual/mta )"
+PROVIDE="virtual/mta"
+
+src_compile () {
+ local myconf
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=gnutls"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=openssl"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf \
+ $(use_enable sasl gsasl) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install failed"
+
+ if use mailwrapper; then
+ insinto /etc/mail
+ doins ${FILESDIR}/mailer.conf
+ else
+ dodir /usr/sbin /usr/lib
+ dosym /usr/bin/msmtp /usr/sbin/sendmail || die "dosym failed"
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS \
+ doc/{Mutt+msmtp.txt,msmtprc*} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/msmtp.html || die "dohtml failed"
+ dodoc doc/msmtp.pdf
+ fi
+}