summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alsaplayer')
-rw-r--r--media-sound/alsaplayer/ChangeLog12
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.60-r1.ebuild (renamed from media-sound/alsaplayer/alsaplayer-0.99.59.ebuild)37
-rw-r--r--media-sound/alsaplayer/files/digest-alsaplayer-0.99.591
-rw-r--r--media-sound/alsaplayer/files/digest-alsaplayer-0.99.60-r11
4 files changed, 38 insertions, 13 deletions
diff --git a/media-sound/alsaplayer/ChangeLog b/media-sound/alsaplayer/ChangeLog
index f4368926506a..18f56711cc91 100644
--- a/media-sound/alsaplayer/ChangeLog
+++ b/media-sound/alsaplayer/ChangeLog
@@ -1,13 +1,21 @@
# ChangeLog for media-sound/alsaplayer
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.2 2002/05/03 04:09:41 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.3 2002/05/04 13:35:03 seemant Exp $
+
+*alsaplayer-0.99.60-r1 (4 May 2002)
+
+ 4 May 2002; Seemant Kulleen <seemant@gentoo.org> alsaplayer-0.99.60-r1.ebuild
+ files/digest-alsaplayer-0.99.60-r1 :
+
+ Rachel Holmes pointed out that ALSA is not a requirement but an optional
+ dependency. Also added nls optional and fixed oggvorbis optional.
*alsaplayer-0.99.60 (2 May 2002)
2 May 2002; Seemant Kulleen <seemant@gentoo.org> alsaplayer-0.99.60.ebuild
files/digest-alsaplayer-0.99.60
- Version bump.
+ Version bump, thanks to Rachel Holmes.
*alsaplayer-0.99.59 (26 Apr 2002)
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.59.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.60-r1.ebuild
index d608ef376070..ea1a279006a7 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.59.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.60-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Seemant Kulleen <seemant@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.59.ebuild,v 1.1 2002/04/26 19:33:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.60-r1.ebuild,v 1.1 2002/05/04 13:35:03 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Media player primarily utilising ALSA"
@@ -9,42 +9,59 @@ SRC_URI="http://www.alsaplayer.org/${P}.tar.bz2"
HOMEPAGE="http://www.alsa-project.org/"
QTROOT="/usr/qt/3"
-DEPEND=">=media-libs/alsa-lib-0.5.10
+DEPEND="alsa? ( >=media-libs/alsa-lib-0.5.10 )
qt? ( >=x11-libs/qt-3.0.1 )
esd? ( media-sound/esound )
gtk? ( x11-libs/gtk+ )
+ opengl? ( virtual/opengl )
oggvorbis? ( media-libs/libvorbis )
>=media-libs/libmikmod-3.1.10
>=dev-libs/glib-1.2.10"
+RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
local myconf
use oggvorbis \
- || myconf="--enable-vorbis=no"
+ && myconf="--enable-oggvorbis" \
+ || myconf="--disable-oggvorbis --disable-oggtest --disable-vorbistest"
use oss \
- || myconf="${myconf} --enable-oss=no"
+ && myconf="${myconf} --enable-oss" \
+ || myconf="${myconf} --disable-oss"
use esd \
- && myconf="${myconf} --enable-audiofile=yes" \
- || myconf="${myconf} --enable-esd=no"
+ && myconf="${myconf} --enable-esd" \
+ || myconf="${myconf} --disable-esd --disable-esdtest"
use nas \
- && myconf="${myconf} --enable-nas=yes"
+ && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ use opengl \
+ && myconf="${myconf} --enable-opengl" \
+ || myconf="${myconf} --disable-opengl"
use gtk \
- || myconf="${myconf} --enable-gtk=no"
+ && myconf="${myconf} --enable-gtk" \
+ || myconf="${myconf} --disable-gtk --disable-gtktest --disable-glibtest"
use qt \
- && myconf="${myconf} --enable-qt=yes \
+ && myconf="${myconf} --enable-qt \
--with-qt-libdir=${QTROOT}/lib \
--with-qt-indir=${QTROOT}/include \
--with-qt-bindir=${QTROOT}/bin"
- econf ${myconf} || die
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ econf \
+ --disable-sgi \
+ --disable-sparc \
+ ${myconf} || die
emake || die
}
diff --git a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.59 b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.59
deleted file mode 100644
index 540b702244f6..000000000000
--- a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.59
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1e8a729f7eb415224e68b06e701dbaef alsaplayer-0.99.59.tar.bz2 561990
diff --git a/media-sound/alsaplayer/files/digest-alsaplayer-0.99.60-r1 b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.60-r1
new file mode 100644
index 000000000000..34c7b96ad6bf
--- /dev/null
+++ b/media-sound/alsaplayer/files/digest-alsaplayer-0.99.60-r1
@@ -0,0 +1 @@
+MD5 a1c7a8de18d05db2abf5646d3dd1f62f alsaplayer-0.99.60.tar.bz2 490394