summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/netselect/netselect-0.3-r3.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-0.3-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-0.3-r3.ebuild b/net-analyzer/netselect/netselect-0.3-r3.ebuild
new file mode 100644
index 000000000000..f694ccd0ff9c
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r3.ebuild,v 1.1 2013/03/10 20:06:00 jer Exp $
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping."
+HOMEPAGE="http://alumnit.ca/~apenwarr/netselect/index.html"
+SRC_URI="http://alumnit.ca/~apenwarr/netselect/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-bsd.patch"
+
+ sed -i \
+ -e "s:PREFIX =.*:PREFIX = ${ED}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
+ -e "s:LDFLAGS =.*:LDFLAGS = -g ${LDFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin netselect
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+ dodoc ChangeLog HISTORY README*
+}