summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/ezbounce/ezbounce-1.04a.ebuild')
-rw-r--r--net-irc/ezbounce/ezbounce-1.04a.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/net-irc/ezbounce/ezbounce-1.04a.ebuild b/net-irc/ezbounce/ezbounce-1.04a.ebuild
index bc7bbd0cfe35..06c445d2f763 100644
--- a/net-irc/ezbounce/ezbounce-1.04a.ebuild
+++ b/net-irc/ezbounce/ezbounce-1.04a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.04a.ebuild,v 1.7 2004/09/12 17:05:54 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.04a.ebuild,v 1.8 2005/12/28 21:01:45 vapier Exp $
inherit eutils
@@ -10,29 +10,27 @@ SRC_URI="http://druglord.freelsd.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
-
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="ssl"
+
DEPEND=">=net-misc/mdidentd-1.04a
ssl? ( dev-libs/openssl )"
src_unpack() {
unpack ${A}
-
- epatch ${FILESDIR}/${P}-crash-fix.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-crash-fix.patch
+ epatch "${FILESDIR}"/${P}-c++.patch
}
src_compile() {
- local myconf
-
- use ssl && myconf="${myconf} --with-ssl"
-
- econf ${myconf} || die
- emake || die
+ econf $(use_with ssl) || die
+ emake CXX_OPTIMIZATIONS="${CXXFLAGS}" || die
}
src_install() {
- dobin ezbounce
+ dobin ezbounce || die
+ dosym ezbounce /usr/bin/ezb
dodoc CHANGES TODO README ezb.conf sample.*
doman misc/ezbounce.1
}