summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/lcrzo/ChangeLog14
-rw-r--r--net-libs/lcrzo/files/digest-lcrzo-4.101
-rw-r--r--net-libs/lcrzo/lcrzo-4.10.ebuild50
3 files changed, 54 insertions, 11 deletions
diff --git a/net-libs/lcrzo/ChangeLog b/net-libs/lcrzo/ChangeLog
index 0ec16106ba6f..2cda020b16eb 100644
--- a/net-libs/lcrzo/ChangeLog
+++ b/net-libs/lcrzo/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for net-libs/lcrzo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/ChangeLog,v 1.8 2002/05/04 03:44:40 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/ChangeLog,v 1.9 2002/06/06 19:18:27 woodchip Exp $
+
+*lcrzo-4.10 (6 Jun 2002)
*lcrzo-4.09-r1 (3 May 2002)
-
3 May 2002; Donny Davies <woodchip@gentoo.org> :
-
Added LICENSE, SLOT.
*lcrzo-4.09 (29 Apr 2002)
@@ -21,11 +21,3 @@
*lcrzo-4.04 (18 Feb 2002)
*lcrzo-4.03 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/net-libs/lcrzo/files/digest-lcrzo-4.10 b/net-libs/lcrzo/files/digest-lcrzo-4.10
new file mode 100644
index 000000000000..5d6a888aad22
--- /dev/null
+++ b/net-libs/lcrzo/files/digest-lcrzo-4.10
@@ -0,0 +1 @@
+MD5 5a5598258397ba32aa860b05931eb567 lcrzo-4.10-src.tgz 680598
diff --git a/net-libs/lcrzo/lcrzo-4.10.ebuild b/net-libs/lcrzo/lcrzo-4.10.ebuild
new file mode 100644
index 000000000000..a8d73ef5c68f
--- /dev/null
+++ b/net-libs/lcrzo/lcrzo-4.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/lcrzo-4.10.ebuild,v 1.1 2002/06/06 19:18:27 woodchip Exp $
+
+DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
+HOMEPAGE="http://www.laurentconstantin.com/en/lcrzo/"
+SRC_URI="http://www.laurentconstantin.com/common/${PN}/download/v4/${P}-src.tgz"
+S=${WORKDIR}/${P}-src
+
+DEPEND="virtual/glibc net-libs/libpcap"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}/src
+
+ # genemake checks that these directories exist...
+ mv genemake genemake.orig
+ sed -e "s:/usr/local/include:/usr/include:" \
+ -e "s:/usr/local/lib:/usr/lib:" \
+ -e "s:/usr/local/bin:/usr/bin:" \
+ -e "s:/usr/local/man/man1:/usr/share/man/man1:" \
+ -e "s:/usr/local/man/man3:/usr/share/man/man3:" \
+ genemake.orig > genemake
+
+ chmod 755 genemake
+ ./genemake || die "problem creating Makefile"
+
+ # plug in our CFLAGS and make it install into ${D}...
+ mv Makefile Makefile.orig
+ sed -e "s:^\(GCCOPT=\).*:\1${CFLAGS}:" \
+ -e "s:^\(GCCOPTL=\).*:\1${CFLAGS}:" \
+ -e "s:^\(GCCOPTP=\).*:\1${CFLAGS}:" \
+ -e "s:^\(INSTINCLUDE=\):\1${D}:" \
+ -e "s:^\(INSTLIB=\):\1${D}:" \
+ -e "s:^\(INSTBIN=\):\1${D}:" \
+ -e "s:^\(INSTMAN1=\):\1${D}:" \
+ -e "s:^\(INSTMAN3=\):\1${D}:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ make -C src || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib} /usr/share/man/{man1,man3}
+ make -C src install || die
+ dodoc doc/*.txt
+}