summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/altermime/altermime-0.3.6.ebuild')
-rw-r--r--net-mail/altermime/altermime-0.3.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/altermime/altermime-0.3.6.ebuild b/net-mail/altermime/altermime-0.3.6.ebuild
new file mode 100644
index 000000000000..da73951be10b
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/altermime-0.3.6.ebuild,v 1.1 2005/06/04 09:29:36 tove Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
+HOMEPAGE="http://pldaniels.com/altermime/"
+
+LICENSE="Sendmail"
+KEYWORDS="~x86 ~s390"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "/^CFLAGS[[:space:]]*=/ s/-O2/${CFLAGS}/" ${S}/Makefile || die "sed failed."
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install () {
+ dobin altermime || die "dobin failed."
+ dodoc CHANGELOG INSTALL LICENCE README || die "dodoc failed."
+}